博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
stars
阅读量:7194 次
发布时间:2019-06-29

本文共 2101 字,大约阅读时间需要 7 分钟。

B - Stars
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.  
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.  
You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input

 
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output

 
1 2 1 1 0
 

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int maxn = 32005;
int c[maxn];
int ans[maxn];
int lowbit(int x)  {
    return x&(-x);
}
void add(int x){
    while(x<=maxn){
        c[x]+=1;   x+=lowbit(x);
    }
}
int sum(int x){
    int ret=0;
    while(x>0){
       ret+=c[x];  x-=lowbit(x);
    }
    return ret;
}
int main(){
    int n,x,y,i;
    while(scanf("%d",&n)!=EOF){
        memset(ans,0,sizeof(ans));
        memset(c,0,sizeof(c));
        for(i=0;i<n;i++){
             scanf("%d %d",&x,&y);

             ans[ sum(++x)]++;

             add(x);

        }
        for(i=0;i<n;i++)
        printf("%d\n",ans[i]);

    }

   return 0;

}

转载于:https://www.cnblogs.com/lengxia/p/4387803.html

你可能感兴趣的文章
汇编2——完整的例子集合
查看>>
TP缓存设计方案解析
查看>>
APIO2010 特别行动队
查看>>
Javascript语言精粹之Array常用方法分析
查看>>
HDU Problem 1159 Common Subsequence 【LCS】
查看>>
gdisk分区
查看>>
转载的一个富文本,挺实用的
查看>>
HDU-1711-Number Sequence
查看>>
【8086汇编基础】00--基础知识--各种进制的数据
查看>>
【8086汇编基础】05--常用函数库文件--emu8086.inc
查看>>
数据结构
查看>>
Freemyapps赚取积分终极图文教程
查看>>
[转] 从零构建 vue2 + vue-router + vuex 开发环境到入门,实现基本的登录退出功能...
查看>>
【leetcode】929. Unique Email Addresses
查看>>
常见复杂指针声明的解析(很详细)
查看>>
判断主机、网络字节序和互相转换
查看>>
react 使用webpack打包问题汇总
查看>>
iOS做地图相关需要知道的Tips(二)—— CoreLocation和MapKit框架
查看>>
mysql分表详解
查看>>
webpack笔记
查看>>